dh-octave – Debhelper-based infrastructure for building Octave add-on packages

Since version 3.0 of Octave (a numerical computation software), add-ons can be installed through the pkg.m system. This package provides the infrastructure for packaging such add-ons for Debian, based on debhelper. It replaces the deprecated octave-pkg-dev package. This package contains debhelper-like scripts for building, checking and cleaning the add-on package as well as for generating the substitution variables in debian/control.

This package is intended to be used by the Debian Octave Group and should be of little interest to general users.

Package availability chart
Distribution Base version Our version Architectures
Debian GNU/Linux 10.0 (buster) 0.6.2 0.6.0~bpo9+1+nd1~nd100+1 i386, amd64, sparc, armel
Debian GNU/Linux 8.0 (jessie)   0.6.0~bpo9+1+nd1~nd80+1 i386, amd64, sparc, armel
Debian GNU/Linux 9.0 (stretch)   0.6.0~bpo9+1+nd1~nd90+1 i386, amd64, sparc, armel
Debian testing (bullseye) 0.7.4    
Debian unstable (sid) 0.7.4 0.6.0~bpo9+1+nd1~nd+1 i386, amd64, sparc, armel
Ubuntu 14.04 “Trusty Tahr” (trusty)   0.6.0~bpo9+1+nd1~nd14.04+1 i386, amd64, sparc, armel
Ubuntu 18.04 “Bionic Beaver” (bionic) 0.3.2 0.6.0~bpo9+1+nd1~nd18.04+1 i386, amd64, sparc, armel
Ubuntu 19.04 “Disco Dingo” (disco) 0.6.2    

Comments

blog comments powered by Disqus